作者zaknafein (zak)
看板Network
標題Re: [問答] 請問如何正確地設定VLAN+DHCP
時間Thu Jul 22 15:51:41 2021
//router
ip dhcp pool vlan2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
dns-server 8.8.8.8
ip dhcp pool vlan3
network 192.168.3.0 255.255.255.0
default-router 192.168.3.254
dns-server 8.8.8.8
ip dhcp pool vlan4
network 192.168.4.0 255.255.255.0
default-router 192.168.4.254
dns-server 8.8.8.8
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.254 255.255.255.0
!
interface GigabitEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.254 255.255.255.0
!
interface GigabitEthernet0/0.4
encapsulation dot1Q 4
ip address 192.168.4.254 255.255.255.0
switch
vlan 2
vlan 3
vlan 4
interface FastEthernet0/1
switchport mode trunk
interface Vlan 2
ip address dhcp
!
interface Vlan3
ip address dhcp
!
interface Vlan4
ip address dhcp
※ 引述《wa007123456 (大笨羊)》之銘言:
: 各位好 先貼一下實體拓樸
: https://imgur.com/s0y5Gzo
: Router組態:
: https://justpaste.it/3klhz
: Switch組態:
: https://justpaste.it/3br89
: 請問要怎麼設定出 , 透過Router的DHCP 穿過VLAN後 可以自動指派DHCP
: 另外就是 有了VLAN的電腦 外部網路要如何連入特定節點呢?
: 感謝回答
: 補充一下VLAN的狀態:
: https://justpaste.it/3czy7
: Router狀態:
: https://justpaste.it/3w7j3
: Trunk狀態:
: https://justpaste.it/43sx0
: 作業系統是 : IOS 15
: 路由器是2811
: 交換器是:2960(L2 Switch)
--
▄▄▄▄▄▄ ▄▄▄
▄█▄ ▌▄▄▄
▌ ▄ ▄█▌▄ ▌ ▄ ▌ ▄▄▄▄▄▄
▌ ▄█▄▌▌▄ ▄ ▄▄██▄▌▄▄▄▄
▌ ▌▌▄▄ ▄ ▄▄▄ ▄▄▄▄
▌███▄▄▄▄▌ ▄██▄ ▌▄▄▄▄
--
※ 發信站: 批踢踢實業坊(ptt.cc), 來自: 149.117.216.29 (美國)
※ 文章網址: https://webptt.com/m.aspx?n=bbs/Network/M.1626940304.A.7A0.html
1F:→ wa007123456: 謝謝你^_^ 07/22 15:54
2F:→ wa007123456: 我寄1000P給你...我正在學習網路... 07/22 15:55
3F:→ zaknafein: 這架構是 所謂的 router on a stick 07/22 15:59
4F:→ zaknafein: 網上很多參考 但一般會用 L3 switch 取代 router 07/22 16:00
5F:推 wa007123456: 感謝大大 我知道ROAS 但是就是一知半解qq 07/22 16:06
6F:→ wa007123456: 不管怎麼樣 非常感謝你 07/22 16:06
7F:→ wa007123456: 我會努力加油的 07/22 16:07
8F:推 birdy590: 2960 上面應該不需要 L3 設定~ 不然 PC 要幹嘛? 07/23 02:16
9F:→ zaknafein: 用 svi 測試 dhcp 有無成功 07/23 06:59
10F:→ zaknafein: PC 後續只是指定 access vlan 而已 07/23 07:00